Forums » Support and troubleshooting » Internal Messaging Service is not working... !!!
I am new to fedena. Started using it for evaluation purposes but now deciding to implement it.
My problem is very basic one.
Whenever I try to send any message by using internal messaging system I am welcomed by text that "Your message has been sent"
But actually it isn't.
Even the sent sms is also not present in sent folder of the sender.

Can anyone please help me with this?
Am I missing anything?

Hi asifsajjad,
Are you using windows?
Yes, Surajit I am using Windows 7 (64-Bit)
Open a new windows command prompt, navigate to fedena root directory and execute rake jobs:works RAILS_ENV=production .
Thanks Surajit you made my day :)
Thank you again, Very much...

However, the following edit made it to work:

rake jobs:work RAILS_ENV=production

and a change in the database.yml for production credentials of the SQL Databse.

Can you please tell me what that commands do?
Also do I have to run it once or every time I use fedena?
Secondly, should I run fedena in Development or Production mode?

I will and always be thankful for this knowledge.
Hi I am facing same issue. I have to use RAILS_ENV="production" rake jobs:work then only delayed jobs are running. How to solve this issue plz kindly help me out. Or else there are going in queue and delayed jobs are running until I run the above command manually. Help me in this issue plz