Forums » Rails - gems and plugins » Library Plugin installation.
Hello, I downloaded and installed the plugin library. Everything went well, except for one small error: isn't loading the images into the module. The rest is excellent. Any idea?

For more information my route was as follows:

Rename the directory inside the folder fedena \ vendor \ plugins
Then I ran the command in c: Fedena ---- "rake fedena: plugins: install_all"

Hi jaguar67,
You are using windows os.. and in all fedena plugin "rsync" command is using to copy the all public things to core public folder. rsync command only works in linux os. so for that you need to download a file -
This variable has to be set CYGWIN=nontsec
Hello and thanks for responding.

Currently I'm stuck at this step. I downloaded and installed the file that you have shown me. Now, I do not know what else to do. I have to open a command line? Which commands are required? The file I downloaded, I have to install it in the folder Fedena? Could you send me a step by step, of course, if possible.

Thank you very much.
Yes. You need to add a system variable .. for that check how to add system variables in windows.
variable name is CYGWIN and variable value is nontsec. and open a new command window and install the plugins and run the server..
hi i installed the file in the fedena location and under system properties i set the environment variables ,to variable name is CYGWIN and variable value is nontsec after i run the command "rake fedena:plugins:install_all" but i still dont get any images and the layout of the files are not as its so-posed to be. pls help
The CSS part is not working after installing library plugin . The Icon of the Library is not coming(Dashboard ). And also after click on that all the options are not coming properly due to the absence of CSS.

anyone help
NoMethodError in LibraryController employee_library_details

undefined method `book_reservations' for Employee:0x67b9630

RAILS_ROOT: D:/Projects/SMS/Fedena/Code/Modify/Development/lims2.3
Application Trace | Framework Trace | Full Trace

C:/Program Files/Ruby187/lib/ruby/gems/1.8/gems/activerecord-2.3.5/lib/active_record/attribute_methods.rb:260:in `method_missing'
D:/Projects/SMS/Fedena/Code/Modify/Development/lims2.3/vendor/plugins/fedena_library/app/controllers/library_controller.rb:208:in `employee_library_details'
C:/Program Files/Ruby187/lib/ruby/gems/1.8/gems/actionpack-2.3.5/lib/action_controller/base.rb:1331:in `send'
C:/Program Files/Ruby187/lib/ruby/gems/1.8/gems/actionpack-2.3.5/lib/action_controller/base.rb:1331:in `perform_action_without_filters'
C:/Program Files/Ruby187/lib/ruby/gems/1.8/gems/actionpack-2.3.5/lib/action_controller/filters.rb:617:in `call_filters'
C:/Program Files/Ruby187/lib/ruby/gems/1.8/gems/actionpack-2.3.5/lib/action_controller/filters.rb:610:in `perform_action_without_benchmark'
can somebody help me on above error. I get it when i clieck the library link inside the employee profile